• http://
  • .yourcommunify.com
  • Go!

Install Communify SDK

Access all the SDK documentation: https://github.com/Communify/Communify-php

 

Using composer

The recommended way to install Communify is with Composer. Composer is a dependency management tool for PHP that allows you to declare the dependencies your project needs and installs them into your project.

# Install Composer
curl -sS https://getcomposer.org/installer | php

You can add Communify as a dependency using the composer.phar CLI:

php composer.phar require communify/communify-php:dev-master

Alternatively, you can specify Communify as a dependency in your project's existing composer.json file:

 {
   "require": {
      "communify/communify-php": "dev-master"
   }
}

After installing, you need to require Composer's autoloader:

require 'vendor/autoload.php';

You can find out more on how to install Composer, configure autoloading, and other best-practices for defining dependencies at getcomposer.org.